Unable to Connect to Server

Stephen Vargo -

SureLC updated our system to support Transport Layer Security (TLS) 1.1 and TLS 1.2.  This is due to the TLS 1.0 encryption being disabled, please Click Here for more information.  Due to this update you might receive an error message saying you can not connect to our servers.  If you receive this message, please follow this guide to resolve this issue.

 If you are a MAC User, please Click Here

 

Windows 7/8/10 Solution:

Step 1.  Close SureLC

Step 2.  Open Internet Explorer

Step 3. Click on the 'Gear' icon or 'Tools', and choose 'Internet Options'

Step 4.  Choose Advanced

Step 5.  Scroll to the bottom, and ensure that 'Use TLS 1.1' and 'Use TLS 1.2' are checked.  If you do NOT see these checkboxes, please ensure that your system meets the SureLC's Minimum Requirements

Step 6.  Hit 'Apply' or 'OK'

Step 7. Reopen SureLC

If you have no error message, log in.  If you have an error message starting SureLC - email support@surancebay.com to escalate to Tier II support.

 

MAC Users

Versions of OS X lower than 10.9 do not support the minimum security requirements for using SureLC on your desktop.

If you do not update your operating system to meet our Minimum Requirements, you are still able to use the web version of SureLC through Firefox or Google Chrome, which both meet our security requirements of supporting TLS 1.1 and TLS 1.2.

If you have additional questions about this issue, please contact support@surancebay.com.

 

Have more questions? Submit a request

Comments